source: dasscm/trunk/debian/rules@ 917

Last change on this file since 917 was 917, checked in by joergs, on Jul 18, 2010 at 9:23:00 PM

debian plugin support, removed dependencies

  • Property svn:executable set to *
File size: 2.4 KB
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10export DH_VERBOSE=1
11
12export DH_COMPAT=4
13
14
15
16
17CFLAGS = -Wall -g
18
19ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21else
22 CFLAGS += -O2
23endif
24
25configure: configure-stamp
26configure-stamp:
27 dh_testdir
28 # Add here commands to configure the package.
29
30 touch configure-stamp
31
32
33build: build-stamp
34
35build-stamp: configure-stamp
36 dh_testdir
37
38 # Add here commands to compile the package.
39 #$(MAKE)
40 #docbook-to-man debian/dasscm.sgml > dasscm.1
41
42 touch $@
43
44clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp configure-stamp
48
49 # Add here commands to clean up after the build process.
50 # -$(MAKE) clean
51
52 dh_clean
53
54install: build
55 dh_testdir
56 dh_testroot
57 dh_clean -k
58 dh_installdirs
59
60 # Add here commands to install the package into debian/dasscm.
61 #$(MAKE) DESTDIR=$(CURDIR)/debian/dasscm install
62 install -d $(CURDIR)/debian/dasscm/usr/bin
63 install -d $(CURDIR)/debian/dasscm/etc
64 #install -d $(CURDIR)/debian/dasscm/etc/subversion
65 install -d $(CURDIR)/var/lib/dasscm/
66 install -d $(CURDIR)/var/lib/dasscm/plugin-results/
67 install -m 0755 usr/bin/dasscm $(CURDIR)/debian/dasscm/usr/bin
68 install -m 0755 usr/bin/dasscm_remote_update.sh $(CURDIR)/debian/dasscm/usr/bin
69 install -m 0644 etc/dasscm.conf $(CURDIR)/debian/dasscm/etc
70 #install -m 0644 subversion-servers.dass-it $(CURDIR)/debian/dasscm/etc/subversion/servers.dass-it
71
72# Build architecture-independent files here.
73binary-indep: build install
74# We have nothing to do by default.
75
76# Build architecture-dependent files here.
77binary-arch: build install
78 dh_testdir
79 dh_testroot
80 dh_installchangelogs
81 dh_installdocs
82 dh_installexamples
83# dh_install
84# dh_installmenu
85# dh_installdebconf
86# dh_installlogrotate
87# dh_installemacsen
88# dh_installpam
89# dh_installmime
90# dh_pysupport
91# dh_installinit
92# dh_installcron
93# dh_installinfo
94 dh_installman
95 dh_link
96 dh_strip
97 dh_compress
98 dh_fixperms
99 dh_perl
100# dh_makeshlibs
101 dh_installdeb
102 dh_shlibdeps
103 dh_gencontrol
104 dh_md5sums
105 dh_builddeb
106
107binary: binary-indep binary-arch
108.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.