source: dasscm/trunk/dasscm.spec@ 1247

Last change on this file since 1247 was 1247, checked in by joergs, on Jan 7, 2020 at 12:28:33 PM

build fix

  • Property svn:keywords set to Id
File size: 2.8 KB
RevLine 
[200]1#
[1159]2# Copyright (c) 2004-2013 dass IT GmbH, Koeln, Germany.
[200]3# This file and all modifications and additions to the pristine
4# package are under the same license as the package itself.
5#
[214]6# $Id: dasscm.spec 1247 2020-01-07 11:28:33Z joergs $
[200]7
[214]8Name: dasscm
[745]9URL: https://trac.dass-it.de/pub/
[1122]10License: GPL-2.0+
[214]11Group: Development/Tools/Version Control
12Autoreqprov: on
[1122]13Summary: DASS Configuration Management
[921]14Version: 1.2
[214]15Release: 0
[915]16Requires: subversion perl
[746]17Source: %{name}_%{version}.orig.tar.gz
[232]18BuildRoot: %{_tmppath}/%{name}-%{version}-build
[214]19BuildArch: noarch
[246]20%if 0%{?suse_version}
[1243]21BuildRequires: gzip tar
[232]22%endif
[1123]23#BuildRequires: nagios-nrpe
[264]24
[265]25# Subversion should be installed during build
26# to have the directory /etc/subversion/ available.
27# Unfortunally, it isn't included in all distributions,
28# therefore we added some checks
[1122]29##if 0#{?suse_version} > 1100
[272]30#BuildRequires: subversion
[1122]31##endif
[263]32
[200]33
34%description
[245]35dasscm is a tool for handling configuration files with subversion
[200]36
37%prep
[745]38%setup -c
[200]39
40
41
42%build
43
[896]44
[200]45%install
[1122]46# call install script
47./dasscm.install.sh DESTDIR=$RPM_BUILD_ROOT
[932]48
[1122]49# handle special files, not useful on all distributions
[1123]50rm -f files
51touch files
52if test -e $RPM_BUILD_ROOT/etc/bash_completion.d/dasscm.sh; then
53 echo '%config(noreplace) /etc/bash_completion.d/dasscm.sh' >> files
54else
55 echo '%doc etc/bash_completion.d/bash_completion_dasscm.sh' >> files
56fi
[200]57
[1123]58if test -e $RPM_BUILD_ROOT/etc/nagios/nrpe.d/dasscm.cfg; then
[1245]59 #test -d /etc/nagios || echo '%%dir /etc/nagios' >> files
60 #test -d /etc/nagios/nrpe.d || echo '%%dir /etc/nagios/nrpe.d' >> files
[1123]61 echo '%config(noreplace) /etc/nagios/nrpe.d/dasscm.cfg' >> files
62else
63 echo '%doc etc/nagios/nrpe.d/nrpe-dasscm.cfg' >> files
64fi
[200]65
[1123]66#cat files
67
68
[200]69%clean
[896]70[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
[200]71
[281]72# TODO: group dasscm: 4199
[1122]73# without existing group, #attr(640,root,4199) falls back to root
[763]74# groupadd -g 4199 dasscm
[200]75
[1123]76%files -f files
[200]77%defattr(-,root,root)
[214]78%dir /var/lib/dasscm/
[916]79%dir /var/lib/dasscm/plugin-results/
[215]80/usr/bin/dasscm
[1168]81/usr/bin/dasscm_remote_check.sh
[807]82/usr/bin/dasscm_remote_update.sh
[1247]83%doc doc/README doc/*.txt doc/*.pl subversion-servers.dass-it
[902]84
[933]85%config(noreplace) %attr(640,root,root) /etc/dasscm.conf
[1122]86%config(noreplace) /etc/profile.d/dasscm.sh
[902]87
[921]88# /etc/sudoers.d/ should not belong to dasscm,
89# but is does currently not exist on most distributions
[1233]90# on Fedora, RHEL/CentOS > 6 produces conflict with sudo package
91# if it is also owned by this package
92%if ! 0%{?fedora} && ! 0%{?rhel_version} && ! 0%{?centos_version}
[1245]93%dir /etc/nagios/
94%dir /etc/nagios/nrpe.d/
[921]95%dir /etc/sudoers.d/
[1233]96%endif
[927]97# sudo requires permissions 440 and config files without any "."
98%attr(440,root,root) %config(noreplace) /etc/sudoers.d/nagios_dasscm_check
Note: See TracBrowser for help on using the repository browser.