source: dasscm/trunk/debian/rules@ 1269

Last change on this file since 1269 was 1269, checked in by joergs, on Nov 25, 2022 at 1:07:58 PM

cleanup

  • Property svn:executable set to *
File size: 1.9 KB
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10export DH_VERBOSE=1
11
12CFLAGS = -Wall -g
13
14ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15 CFLAGS += -O0
16else
17 CFLAGS += -O2
18endif
19
20configure: configure-stamp
21configure-stamp:
22 dh_testdir
23 # Add here commands to configure the package.
24
25 touch configure-stamp
26
27
28build: build-stamp
29
30build-stamp: configure-stamp
31 dh_testdir
32
33 # Add here commands to compile the package.
34 #$(MAKE)
35 #docbook-to-man debian/dasscm.sgml > dasscm.1
36
37 touch $@
38
39clean:
40 dh_testdir
41 dh_testroot
42 rm -f build-stamp configure-stamp
43
44 # Add here commands to clean up after the build process.
45 # -$(MAKE) clean
46
47 dh_clean
48
49install: build
50 dh_testdir
51 dh_testroot
52 dh_clean -k
53 dh_installdirs
54
55 # Add here commands to install the package into debian/dasscm.
56 #$(MAKE) DESTDIR=$(CURDIR)/debian/dasscm install
57 ./dasscm.install.sh DESTDIR=$(CURDIR)/debian/dasscm
58
59# Build architecture-independent files here.
60binary-indep: build install
61# We have nothing to do by default.
62
63# Build architecture-dependent files here.
64binary-arch: build install
65 dh_testdir
66 dh_testroot
67 dh_installchangelogs
68 dh_installdocs
69 dh_installexamples
70# dh_install
71# dh_installmenu
72# dh_installdebconf
73# dh_installlogrotate
74# dh_installemacsen
75# dh_installpam
76# dh_installmime
77# dh_pysupport
78# dh_installinit
79# dh_installcron
80# dh_installinfo
81 dh_installman
82 dh_link
83 dh_strip
84 dh_compress
85 dh_fixperms
86 dh_perl
87# dh_makeshlibs
88 dh_installdeb
89 dh_shlibdeps
90 dh_gencontrol
91 dh_md5sums
92 dh_builddeb
93
94binary: binary-indep binary-arch
95.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.