source: kde/kdeutils-cmd.spec@ 1144

Last change on this file since 1144 was 942, checked in by joergs, on Dec 9, 2010 at 10:16:33 PM

add knotify-recipient.py

  • Property svn:keywords set to Id
File size: 1.5 KB
Line 
1#
2# spec file for KDE command line admin utilities
3#
4# Copyright (c) 2009-2010 dass IT GmbH Cologne, Germany.
5# This file and all modifications and additions to the pristine
6# package are under the same license as the package itself.
7#
8
9#
10# $Id: kdeutils-cmd.spec 942 2010-12-09 21:16:33Z joergs $
11#
12
13%define KDE_VER 4
14#define KDE_ENV_DIR /opt/kde3/env
15%define KDE_ENV_DIR /usr/share/kde4/env/
16
17Name: kdeutils-cmd
18License: GPL
19Group: Applications/Communications
20Summary: KDE%{KDE_VER}: commandline utilities
21Version: 0.1
22Release: 0
23Autoreqprov: on
24# libqt4 includes qdbus (openSUSE 11.2)
25Requires: libqt4
26Requires: python-kde4
27Source: %{name}-%{version}.orig.tar.gz
28BuildRoot: %{_tmppath}/%{name}-%{version}-build
29BuildArch: noarch
30#BuildRequires: kdebase4-openSUSE
31
32
33
34
35%description
36some KDE and dbus commandline utilities
37
38Authors:
39--------
40 Joerg Steffens, dass IT
41
42
43
44
45%prep
46%setup -c
47
48
49
50%build
51
52
53
54%install
55mkdir -p $RPM_BUILD_ROOT/usr/bin
56INSTALL="install"
57$INSTALL -m 755 kreadconfig/*.py $RPM_BUILD_ROOT/usr/bin/
58ln -s kreadconfig.py $RPM_BUILD_ROOT/usr/bin/kread-config.py
59$INSTALL -m 755 dbus/*.sh $RPM_BUILD_ROOT/usr/bin/
60$INSTALL -m 755 dbus/*.py $RPM_BUILD_ROOT/usr/bin/
61$INSTALL -m 755 dbus/knotify-client $RPM_BUILD_ROOT/usr/bin/
62
63%clean
64[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
65
66%files
67%defattr(-,root,root)
68%doc Changes
69#doc kreadconfig/kreadconfig-test.sh
70#doc kreadconfig/kread-desktopfile-test.sh
71#doc kreadconfig/test/
72 /usr/bin/*
Note: See TracBrowser for help on using the repository browser.