source: opsi/server/wsusoffline/wsusoffline.spec@ 1004

Last change on this file since 1004 was 1004, checked in by joergs, on May 15, 2012 at 4:11:04 PM

Bugfix: added BuildRoot

File size: 2.1 KB
RevLine 
[1000]1#
2# spec file for package [spectemplate]
3#
[1001]4# Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
[1000]5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
[1001]15# Please submit bugfixes or comments via packager@dass-it.de
[1000]16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
21Version: 7.3.1
22%define ver "731"
23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
[1004]28BuildRoot: %{_tmppath}/%{name}-%{version}-build
[1000]29BuildRequires: unzip
[1001]30Requires: cabextract dos2unix md5deep xmlstarlet wget
[1000]31BuildArch: noarch
32
33%description
[1001]34"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
[1002]35This includes Windows, Office and some extensions like dotnet or Powershell.
[1001]36After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
37Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
[1000]38
39%prep
40%setup -c
41
42
43%build
44
45
46
47%install
48%define DEST_DIR "/var/lib/wsusoffline/"
49mkdir -p $RPM_BUILD_ROOT/var/lib/
50unzip %{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
51chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
[1001]52mkdir -p $RPM_BUILD_ROOT/usr/bin/
53ln -s %{DEST_DIR}/sh/DownloadUpdates.sh $RPM_BUILD_ROOT/usr/bin/wsus-download-updates.sh
54ln -s %{DEST_DIR}/sh/CreateISOImage.sh $RPM_BUILD_ROOT/usr/bin/wsus-create-iso-image.sh
[1000]55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root)
61%{DEST_DIR}
[1001]62/usr/bin/wsus-*.sh
[1000]63
64
65
66%changelog
Note: See TracBrowser for help on using the repository browser.