source: opsi/server/wsusoffline/wsusoffline.spec@ 1060

Last change on this file since 1060 was 1060, checked in by joergs, on Aug 15, 2012 at 4:42:56 PM

back to 7.4.1, because this is the last version containing linux scipts

File size: 3.1 KB
RevLine 
[1000]1#
2# spec file for package [spectemplate]
3#
[1001]4# Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
[1000]5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
[1001]15# Please submit bugfixes or comments via packager@dass-it.de
[1000]16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
[1060]21Version: 7.4.1
22%define ver "741"
[1000]23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
[1014]28#Source99: #{name}-rpmlintrc
[1004]29BuildRoot: %{_tmppath}/%{name}-%{version}-build
[1017]30BuildRequires: unzip
31
32# for goupadd
[1018]33%if 0%{?suse_version}
[1020]34Requires(pre): pwdutils
35%else
[1018]36#Requires(pre): shadow-utils
[1020]37Requires(pre): /usr/bin/groupadd
[1017]38%endif
39
[1001]40Requires: cabextract dos2unix md5deep xmlstarlet wget
[1000]41BuildArch: noarch
42
43%description
[1001]44"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
[1002]45This includes Windows, Office and some extensions like dotnet or Powershell.
[1001]46After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
47Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
[1000]48
49%prep
50%setup -c
51
52
53%build
54
55
56
57%install
[1010]58%define DEST_DIR /var/lib/wsusoffline/
[1000]59mkdir -p $RPM_BUILD_ROOT/var/lib/
[1008]60unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
[1016]61install -d $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
62
63
64# remove windows only stuff
[1010]65rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe
66rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3
67rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin
68rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd
[1013]69
[1016]70# adapt permissions
71chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}
72find $RPM_BUILD_ROOT/%{DEST_DIR}/client/ -type d -exec chmod g+ws {} \;
73chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/exclude/
74chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/log/
75chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/iso/
76chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/sh/
77chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
78chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
79
80
81# install start wrapper scripts
[1001]82mkdir -p $RPM_BUILD_ROOT/usr/bin/
[1011]83install wsusoffline/*.sh $RPM_BUILD_ROOT/usr/bin/
[1000]84
[1016]85
86
[1000]87%clean
88rm -rf %{buildroot}
89
[1008]90%pre
91getent group wsusoffline >/dev/null || groupadd -r wsusoffline
92
[1016]93
[1000]94%files
95%defattr(-,root,root)
[1008]96/usr/bin/wsus-*.sh
[1016]97%dir %{DEST_DIR}
[1010]98# #{DEST_DIR}/bin
99# #{DEST_DIR}/cmd
100%{DEST_DIR}/doc
101%{DEST_DIR}/static
102%{DEST_DIR}/xslt
103
[1008]104%defattr(-,root,wsusoffline)
105%{DEST_DIR}/client/
[1013]106%{DEST_DIR}/exclude/
[1010]107%{DEST_DIR}/iso/
108%{DEST_DIR}/log/
[1012]109%{DEST_DIR}/sh/
[1010]110%{DEST_DIR}/temp/
[1000]111
112%changelog
Note: See TracBrowser for help on using the repository browser.