source: opsi/server/wsusoffline/wsusoffline.spec@ 1144

Last change on this file since 1144 was 1144, checked in by joergs, on Mar 27, 2013 at 11:35:53 AM

workaround: checkconnection file permissions

File size: 3.3 KB
RevLine 
[1000]1#
[1135]2# spec file for package
[1000]3#
[1135]4# Copyright (c) 2013 dass IT GmbH, Cologne, Germany.
[1000]5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
[1001]15# Please submit bugfixes or comments via packager@dass-it.de
[1000]16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
[1136]21Version: 8.0.0
[1135]22%define ver "80"
[1000]23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
[1014]28#Source99: #{name}-rpmlintrc
[1004]29BuildRoot: %{_tmppath}/%{name}-%{version}-build
[1017]30BuildRequires: unzip
31
32# for goupadd
[1018]33%if 0%{?suse_version}
[1020]34Requires(pre): pwdutils
35%else
[1018]36#Requires(pre): shadow-utils
[1020]37Requires(pre): /usr/bin/groupadd
[1017]38%endif
39
[1135]40Requires: cabextract md5deep xmlstarlet wget
[1000]41BuildArch: noarch
42
43%description
[1001]44"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
[1002]45This includes Windows, Office and some extensions like dotnet or Powershell.
[1001]46After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
47Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
[1000]48
49%prep
50%setup -c
51
52
53%build
54
55
56
57%install
[1010]58%define DEST_DIR /var/lib/wsusoffline/
[1000]59mkdir -p $RPM_BUILD_ROOT/var/lib/
[1008]60unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
[1142]61PATCH=$PWD/wsusoffline/download-updates.patch
62cd $RPM_BUILD_ROOT/%{DEST_DIR}
63patch -p1 < $PATCH
64cd -
[1016]65install -d $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
66
67
68# remove windows only stuff
[1010]69rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe
70rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3
71rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin
72rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd
[1013]73
[1016]74# adapt permissions
75chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}
76find $RPM_BUILD_ROOT/%{DEST_DIR}/client/ -type d -exec chmod g+ws {} \;
77chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/exclude/
78chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/log/
79chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/iso/
[1141]80# checkconnection downloads file into this directory
81chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/sh/
[1016]82chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
[1140]83find $RPM_BUILD_ROOT/%{DEST_DIR}/static/ -type d -exec chmod g+ws {} \;
[1016]84chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
85
86
87# install start wrapper scripts
[1001]88mkdir -p $RPM_BUILD_ROOT/usr/bin/
[1011]89install wsusoffline/*.sh $RPM_BUILD_ROOT/usr/bin/
[1000]90
[1016]91
92
[1000]93%clean
94rm -rf %{buildroot}
95
[1008]96%pre
97getent group wsusoffline >/dev/null || groupadd -r wsusoffline
98
[1016]99
[1000]100%files
101%defattr(-,root,root)
[1008]102/usr/bin/wsus-*.sh
[1016]103%dir %{DEST_DIR}
[1010]104# #{DEST_DIR}/bin
105# #{DEST_DIR}/cmd
[1138]106%{DEST_DIR}/doc/
107%{DEST_DIR}/xslt/
[1010]108
[1008]109%defattr(-,root,wsusoffline)
110%{DEST_DIR}/client/
[1013]111%{DEST_DIR}/exclude/
[1010]112%{DEST_DIR}/iso/
113%{DEST_DIR}/log/
[1144]114# write access required, but only for checkconnection
115%{DEST_DIR}/sh/
[1138]116%{DEST_DIR}/static
[1010]117%{DEST_DIR}/temp/
[1000]118
119%changelog
Note: See TracBrowser for help on using the repository browser.