1 | #
|
---|
2 | # spec file for package [spectemplate]
|
---|
3 | #
|
---|
4 | # Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
|
---|
5 | #
|
---|
6 | # All modifications and additions to the file contributed by third parties
|
---|
7 | # remain the property of their copyright owners, unless otherwise agreed
|
---|
8 | # upon. The license for this file, and modifications and additions to the
|
---|
9 | # file, is the same license as for the pristine package itself (unless the
|
---|
10 | # license for the pristine package is not an Open Source License, in which
|
---|
11 | # case the license is the MIT License). An "Open Source License" is a
|
---|
12 | # license that conforms to the Open Source Definition (Version 1.9)
|
---|
13 | # published by the Open Source Initiative.
|
---|
14 |
|
---|
15 | # Please submit bugfixes or comments via packager@dass-it.de
|
---|
16 | #
|
---|
17 | # norootforbuild
|
---|
18 |
|
---|
19 | Name: wsusoffline
|
---|
20 | Group: System/Management
|
---|
21 | Version: 7.3.2
|
---|
22 | %define ver "732"
|
---|
23 | Release: 1
|
---|
24 | Summary: WSUS Offline Update: download Microsoft updates
|
---|
25 | License: GPLv2+
|
---|
26 | URL: http://www.wsusoffline.net/
|
---|
27 | Source: %{name}_%{version}.orig.tar.gz
|
---|
28 | BuildRoot: %{_tmppath}/%{name}-%{version}-build
|
---|
29 | BuildRequires: unzip pwdutils
|
---|
30 | Requires: cabextract dos2unix md5deep xmlstarlet wget
|
---|
31 | BuildArch: noarch
|
---|
32 |
|
---|
33 | %description
|
---|
34 | "WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
|
---|
35 | This includes Windows, Office and some extensions like dotnet or Powershell.
|
---|
36 | After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
|
---|
37 | Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
|
---|
38 |
|
---|
39 | %prep
|
---|
40 | %setup -c
|
---|
41 |
|
---|
42 |
|
---|
43 | %build
|
---|
44 |
|
---|
45 |
|
---|
46 |
|
---|
47 | %install
|
---|
48 | %define DEST_DIR /var/lib/wsusoffline/
|
---|
49 | mkdir -p $RPM_BUILD_ROOT/var/lib/
|
---|
50 | unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
|
---|
51 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe
|
---|
52 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3
|
---|
53 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin
|
---|
54 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd
|
---|
55 | chmod -R g+w $RPM_BUILD_ROOT/%{DEST_DIR}/client/
|
---|
56 | chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
|
---|
57 | mkdir -p $RPM_BUILD_ROOT/usr/bin/
|
---|
58 | ln -s %{DEST_DIR}/sh/DownloadUpdates.sh $RPM_BUILD_ROOT/usr/bin/wsus-download-updates.sh
|
---|
59 | ln -s %{DEST_DIR}/sh/CreateISOImage.sh $RPM_BUILD_ROOT/usr/bin/wsus-create-iso-image.sh
|
---|
60 |
|
---|
61 | %clean
|
---|
62 | rm -rf %{buildroot}
|
---|
63 |
|
---|
64 | %pre
|
---|
65 | getent group wsusoffline >/dev/null || groupadd -r wsusoffline
|
---|
66 | exit 0
|
---|
67 |
|
---|
68 | %files
|
---|
69 | %defattr(-,root,root)
|
---|
70 | /usr/bin/wsus-*.sh
|
---|
71 | %dir %{DEST_DIR}
|
---|
72 | # #{DEST_DIR}/bin
|
---|
73 | # #{DEST_DIR}/cmd
|
---|
74 | %{DEST_DIR}/doc
|
---|
75 | %{DEST_DIR}/exclude
|
---|
76 | %{DEST_DIR}/sh
|
---|
77 | %{DEST_DIR}/static
|
---|
78 | %{DEST_DIR}/xslt
|
---|
79 |
|
---|
80 | %defattr(-,root,wsusoffline)
|
---|
81 | %{DEST_DIR}/client/
|
---|
82 | %{DEST_DIR}/iso/
|
---|
83 | %{DEST_DIR}/log/
|
---|
84 | %{DEST_DIR}/temp/
|
---|
85 |
|
---|
86 |
|
---|
87 |
|
---|
88 | %changelog
|
---|