source: opsi/server/wsusoffline/wsusoffline.spec@ 1001

Last change on this file since 1001 was 1001, checked in by joergs, on May 11, 2012 at 7:01:52 PM

beautified

File size: 2.1 KB
Line 
1#
2# spec file for package [spectemplate]
3#
4# Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via packager@dass-it.de
16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
21Version: 7.3.1
22%define ver "731"
23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
28
29BuildRequires: unzip
30Requires: cabextract dos2unix md5deep xmlstarlet wget
31BuildArch: noarch
32
33%description
34"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
35This includes Windows, Office and some extensions like dotNet or Powershell.
36After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
37Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
38
39%prep
40%setup -c
41
42
43%build
44
45
46
47%install
48%define DEST_DIR "/var/lib/wsusoffline/"
49mkdir -p $RPM_BUILD_ROOT/var/lib/
50unzip %{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
51chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
52mkdir -p $RPM_BUILD_ROOT/usr/bin/
53ln -s %{DEST_DIR}/sh/DownloadUpdates.sh $RPM_BUILD_ROOT/usr/bin/wsus-download-updates.sh
54ln -s %{DEST_DIR}/sh/CreateISOImage.sh $RPM_BUILD_ROOT/usr/bin/wsus-create-iso-image.sh
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root)
61%{DEST_DIR}
62/usr/bin/wsus-*.sh
63
64
65
66%changelog
Note: See TracBrowser for help on using the repository browser.