source: opsi/server/wsusoffline/wsusoffline.spec@ 1017

Last change on this file since 1017 was 1017, checked in by joergs, on Jun 5, 2012 at 8:13:46 AM

groupadd for fedora

File size: 3.0 KB
Line 
1#
2# spec file for package [spectemplate]
3#
4# Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via packager@dass-it.de
16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
21Version: 7.3.2
22%define ver "732"
23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
28#Source99: #{name}-rpmlintrc
29BuildRoot: %{_tmppath}/%{name}-%{version}-build
30BuildRequires: unzip
31
32# for goupadd
33%if 0%{?fedora}
34Requires(pre): shadow-utils
35%else
36Requires(pre): pwdutils
37%endif
38
39Requires: cabextract dos2unix md5deep xmlstarlet wget
40BuildArch: noarch
41
42%description
43"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
44This includes Windows, Office and some extensions like dotnet or Powershell.
45After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
46Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
47
48%prep
49%setup -c
50
51
52%build
53
54
55
56%install
57%define DEST_DIR /var/lib/wsusoffline/
58mkdir -p $RPM_BUILD_ROOT/var/lib/
59unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
60install -d $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
61
62
63# remove windows only stuff
64rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe
65rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3
66rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin
67rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd
68
69# adapt permissions
70chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}
71find $RPM_BUILD_ROOT/%{DEST_DIR}/client/ -type d -exec chmod g+ws {} \;
72chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/exclude/
73chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/log/
74chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/iso/
75chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/sh/
76chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
77chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
78
79
80# install start wrapper scripts
81mkdir -p $RPM_BUILD_ROOT/usr/bin/
82install wsusoffline/*.sh $RPM_BUILD_ROOT/usr/bin/
83
84
85
86%clean
87rm -rf %{buildroot}
88
89%pre
90getent group wsusoffline >/dev/null || groupadd -r wsusoffline
91
92
93%files
94%defattr(-,root,root)
95/usr/bin/wsus-*.sh
96%dir %{DEST_DIR}
97# #{DEST_DIR}/bin
98# #{DEST_DIR}/cmd
99%{DEST_DIR}/doc
100%{DEST_DIR}/static
101%{DEST_DIR}/xslt
102
103%defattr(-,root,wsusoffline)
104%{DEST_DIR}/client/
105%{DEST_DIR}/exclude/
106%{DEST_DIR}/iso/
107%{DEST_DIR}/log/
108%{DEST_DIR}/sh/
109%{DEST_DIR}/temp/
110
111%changelog
Note: See TracBrowser for help on using the repository browser.