1 | # |
---|
2 | # spec file for package [spectemplate] |
---|
3 | # |
---|
4 | # Copyright (c) 2012 dass IT GmbH, Cologne, Germany. |
---|
5 | # |
---|
6 | # All modifications and additions to the file contributed by third parties |
---|
7 | # remain the property of their copyright owners, unless otherwise agreed |
---|
8 | # upon. The license for this file, and modifications and additions to the |
---|
9 | # file, is the same license as for the pristine package itself (unless the |
---|
10 | # license for the pristine package is not an Open Source License, in which |
---|
11 | # case the license is the MIT License). An "Open Source License" is a |
---|
12 | # license that conforms to the Open Source Definition (Version 1.9) |
---|
13 | # published by the Open Source Initiative. |
---|
14 | |
---|
15 | # Please submit bugfixes or comments via packager@dass-it.de |
---|
16 | # |
---|
17 | # norootforbuild |
---|
18 | |
---|
19 | Name: wsusoffline |
---|
20 | Group: System/Management |
---|
21 | Version: 7.4.1 |
---|
22 | %define ver "741" |
---|
23 | Release: 1 |
---|
24 | Summary: WSUS Offline Update: download Microsoft updates |
---|
25 | License: GPLv2+ |
---|
26 | URL: http://www.wsusoffline.net/ |
---|
27 | Source: %{name}_%{version}.orig.tar.gz |
---|
28 | #Source99: #{name}-rpmlintrc |
---|
29 | BuildRoot: %{_tmppath}/%{name}-%{version}-build |
---|
30 | BuildRequires: unzip |
---|
31 | |
---|
32 | # for goupadd |
---|
33 | %if 0%{?suse_version} |
---|
34 | Requires(pre): pwdutils |
---|
35 | %else |
---|
36 | #Requires(pre): shadow-utils |
---|
37 | Requires(pre): /usr/bin/groupadd |
---|
38 | %endif |
---|
39 | |
---|
40 | Requires: cabextract dos2unix md5deep xmlstarlet wget |
---|
41 | BuildArch: noarch |
---|
42 | |
---|
43 | %description |
---|
44 | "WSUS Offline Update" allows you to download most Microsoft updates and store them localy. |
---|
45 | This includes Windows, Office and some extensions like dotnet or Powershell. |
---|
46 | After downloading, they can be installed on any Microsoft Windows system without an Internet connection. |
---|
47 | Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org |
---|
48 | |
---|
49 | %prep |
---|
50 | %setup -c |
---|
51 | |
---|
52 | |
---|
53 | %build |
---|
54 | |
---|
55 | |
---|
56 | |
---|
57 | %install |
---|
58 | %define DEST_DIR /var/lib/wsusoffline/ |
---|
59 | mkdir -p $RPM_BUILD_ROOT/var/lib/ |
---|
60 | unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/ |
---|
61 | install -d $RPM_BUILD_ROOT/%{DEST_DIR}/temp/ |
---|
62 | |
---|
63 | |
---|
64 | # remove windows only stuff |
---|
65 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe |
---|
66 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3 |
---|
67 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin |
---|
68 | rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd |
---|
69 | |
---|
70 | # adapt permissions |
---|
71 | chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR} |
---|
72 | find $RPM_BUILD_ROOT/%{DEST_DIR}/client/ -type d -exec chmod g+ws {} \; |
---|
73 | chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/exclude/ |
---|
74 | chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/log/ |
---|
75 | chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/iso/ |
---|
76 | chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/sh/ |
---|
77 | chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/* |
---|
78 | chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/temp/ |
---|
79 | |
---|
80 | |
---|
81 | # install start wrapper scripts |
---|
82 | mkdir -p $RPM_BUILD_ROOT/usr/bin/ |
---|
83 | install wsusoffline/*.sh $RPM_BUILD_ROOT/usr/bin/ |
---|
84 | |
---|
85 | |
---|
86 | |
---|
87 | %clean |
---|
88 | rm -rf %{buildroot} |
---|
89 | |
---|
90 | %pre |
---|
91 | getent group wsusoffline >/dev/null || groupadd -r wsusoffline |
---|
92 | |
---|
93 | |
---|
94 | %files |
---|
95 | %defattr(-,root,root) |
---|
96 | /usr/bin/wsus-*.sh |
---|
97 | %dir %{DEST_DIR} |
---|
98 | # #{DEST_DIR}/bin |
---|
99 | # #{DEST_DIR}/cmd |
---|
100 | %{DEST_DIR}/doc |
---|
101 | %{DEST_DIR}/static |
---|
102 | %{DEST_DIR}/xslt |
---|
103 | |
---|
104 | %defattr(-,root,wsusoffline) |
---|
105 | %{DEST_DIR}/client/ |
---|
106 | %{DEST_DIR}/exclude/ |
---|
107 | %{DEST_DIR}/iso/ |
---|
108 | %{DEST_DIR}/log/ |
---|
109 | %{DEST_DIR}/sh/ |
---|
110 | %{DEST_DIR}/temp/ |
---|
111 | |
---|
112 | %changelog |
---|