source: trunk/dasscm/debian/rules@ 266

Last change on this file since 266 was 266, checked in by joergs, on Dec 29, 2008 at 3:27:10 PM

moved /etc/subversion/servers.dass-it to doc/

  • Property svn:executable set to *
File size: 2.3 KB
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10export DH_VERBOSE=1
11
12export DH_COMPAT=4
13
14
15
16
17CFLAGS = -Wall -g
18
19ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21else
22 CFLAGS += -O2
23endif
24
25configure: configure-stamp
26configure-stamp:
27 dh_testdir
28 # Add here commands to configure the package.
29
30 touch configure-stamp
31
32
33build: build-stamp
34
35build-stamp: configure-stamp
36 dh_testdir
37
38 # Add here commands to compile the package.
39 #$(MAKE)
40 #docbook-to-man debian/dasscm.sgml > dasscm.1
41
42 touch $@
43
44clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp configure-stamp
48
49 # Add here commands to clean up after the build process.
50 # -$(MAKE) clean
51
52 dh_clean
53
54install: build
55 dh_testdir
56 dh_testroot
57 dh_clean -k
58 dh_installdirs
59
60 # Add here commands to install the package into debian/dasscm.
61 #$(MAKE) DESTDIR=$(CURDIR)/debian/dasscm install
62 install -d $(CURDIR)/debian/dasscm/usr/bin
63 install -d $(CURDIR)/debian/dasscm/etc
64 install -d $(CURDIR)/debian/dasscm/etc/subversion
65 install -d $(CURDIR)/var/lib/dasscm/
66 install -m 0755 dasscm $(CURDIR)/debian/dasscm/usr/bin
67 install -m 0644 dasscm.conf $(CURDIR)/debian/dasscm/etc
68 #install -m 0644 subversion-servers.dass-it $(CURDIR)/debian/dasscm/etc/subversion/servers.dass-it
69
70# Build architecture-independent files here.
71binary-indep: build install
72# We have nothing to do by default.
73
74# Build architecture-dependent files here.
75binary-arch: build install
76 dh_testdir
77 dh_testroot
78 dh_installchangelogs
79 dh_installdocs
80 dh_installexamples
81# dh_install
82# dh_installmenu
83# dh_installdebconf
84# dh_installlogrotate
85# dh_installemacsen
86# dh_installpam
87# dh_installmime
88# dh_pysupport
89# dh_installinit
90# dh_installcron
91# dh_installinfo
92 dh_installman
93 dh_link
94 dh_strip
95 dh_compress
96 dh_fixperms
97 dh_perl
98# dh_makeshlibs
99 dh_installdeb
100 dh_shlibdeps
101 dh_gencontrol
102 dh_md5sums
103 dh_builddeb
104
105binary: binary-indep binary-arch
106.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.