1 | #!/usr/bin/make -f
|
---|
2 | # -*- makefile -*-
|
---|
3 | # Sample debian/rules that uses debhelper.
|
---|
4 | # This file was originally written by Joey Hess and Craig Small.
|
---|
5 | # As a special exception, when this file is copied by dh-make into a
|
---|
6 | # dh-make output file, you may use that output file without restriction.
|
---|
7 | # This special exception was added by Craig Small in version 0.37 of dh-make.
|
---|
8 |
|
---|
9 | # Uncomment this to turn on verbose mode.
|
---|
10 | export DH_VERBOSE=1
|
---|
11 |
|
---|
12 | export DH_COMPAT=5
|
---|
13 |
|
---|
14 |
|
---|
15 |
|
---|
16 |
|
---|
17 | CFLAGS = -Wall -g
|
---|
18 |
|
---|
19 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
|
---|
20 | CFLAGS += -O0
|
---|
21 | else
|
---|
22 | CFLAGS += -O2
|
---|
23 | endif
|
---|
24 |
|
---|
25 | configure: configure-stamp
|
---|
26 | configure-stamp:
|
---|
27 | dh_testdir
|
---|
28 | # Add here commands to configure the package.
|
---|
29 |
|
---|
30 | touch configure-stamp
|
---|
31 |
|
---|
32 |
|
---|
33 | build: build-stamp
|
---|
34 |
|
---|
35 | build-stamp: configure-stamp
|
---|
36 | dh_testdir
|
---|
37 |
|
---|
38 | # Add here commands to compile the package.
|
---|
39 | #$(MAKE)
|
---|
40 | #docbook-to-man debian/dasscm.sgml > dasscm.1
|
---|
41 |
|
---|
42 | touch $@
|
---|
43 |
|
---|
44 | clean:
|
---|
45 | dh_testdir
|
---|
46 | dh_testroot
|
---|
47 | rm -f build-stamp configure-stamp
|
---|
48 |
|
---|
49 | # Add here commands to clean up after the build process.
|
---|
50 | # -$(MAKE) clean
|
---|
51 |
|
---|
52 | dh_clean
|
---|
53 |
|
---|
54 | install: build
|
---|
55 | dh_testdir
|
---|
56 | dh_testroot
|
---|
57 | dh_clean -k
|
---|
58 | dh_installdirs
|
---|
59 |
|
---|
60 | # Add here commands to install the package into debian/dasscm.
|
---|
61 | #$(MAKE) DESTDIR=$(CURDIR)/debian/dasscm install
|
---|
62 | ./dasscm.install.sh DESTDIR=$(CURDIR)/debian/dasscm
|
---|
63 |
|
---|
64 | # Build architecture-independent files here.
|
---|
65 | binary-indep: build install
|
---|
66 | # We have nothing to do by default.
|
---|
67 |
|
---|
68 | # Build architecture-dependent files here.
|
---|
69 | binary-arch: build install
|
---|
70 | dh_testdir
|
---|
71 | dh_testroot
|
---|
72 | dh_installchangelogs
|
---|
73 | dh_installdocs
|
---|
74 | dh_installexamples
|
---|
75 | # dh_install
|
---|
76 | # dh_installmenu
|
---|
77 | # dh_installdebconf
|
---|
78 | # dh_installlogrotate
|
---|
79 | # dh_installemacsen
|
---|
80 | # dh_installpam
|
---|
81 | # dh_installmime
|
---|
82 | # dh_pysupport
|
---|
83 | # dh_installinit
|
---|
84 | # dh_installcron
|
---|
85 | # dh_installinfo
|
---|
86 | dh_installman
|
---|
87 | dh_link
|
---|
88 | dh_strip
|
---|
89 | dh_compress
|
---|
90 | dh_fixperms
|
---|
91 | dh_perl
|
---|
92 | # dh_makeshlibs
|
---|
93 | dh_installdeb
|
---|
94 | dh_shlibdeps
|
---|
95 | dh_gencontrol
|
---|
96 | dh_md5sums
|
---|
97 | dh_builddeb
|
---|
98 |
|
---|
99 | binary: binary-indep binary-arch
|
---|
100 | .PHONY: build clean binary-indep binary-arch binary install configure
|
---|