source: opsi/server/wsusoffline/wsusoffline.spec@ 1016

Last change on this file since 1016 was 1016, checked in by joergs, on Jun 2, 2012 at 5:53:54 PM

set group permissions

File size: 2.9 KB
RevLine 
[1000]1#
2# spec file for package [spectemplate]
3#
[1001]4# Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
[1000]5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
[1001]15# Please submit bugfixes or comments via packager@dass-it.de
[1000]16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
[1009]21Version: 7.3.2
22%define ver "732"
[1000]23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
[1014]28#Source99: #{name}-rpmlintrc
[1004]29BuildRoot: %{_tmppath}/%{name}-%{version}-build
[1008]30BuildRequires: unzip pwdutils
[1001]31Requires: cabextract dos2unix md5deep xmlstarlet wget
[1000]32BuildArch: noarch
33
34%description
[1001]35"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
[1002]36This includes Windows, Office and some extensions like dotnet or Powershell.
[1001]37After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
38Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
[1000]39
40%prep
41%setup -c
42
43
44%build
45
46
47
48%install
[1010]49%define DEST_DIR /var/lib/wsusoffline/
[1000]50mkdir -p $RPM_BUILD_ROOT/var/lib/
[1008]51unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
[1016]52install -d $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
53
54
55# remove windows only stuff
[1010]56rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe
57rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3
58rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin
59rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd
[1013]60
[1016]61# adapt permissions
62chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}
63find $RPM_BUILD_ROOT/%{DEST_DIR}/client/ -type d -exec chmod g+ws {} \;
64chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/exclude/
65chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/log/
66chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/iso/
67chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/sh/
68chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
69chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
70
71
72# install start wrapper scripts
[1001]73mkdir -p $RPM_BUILD_ROOT/usr/bin/
[1011]74install wsusoffline/*.sh $RPM_BUILD_ROOT/usr/bin/
[1000]75
[1016]76
77
[1000]78%clean
79rm -rf %{buildroot}
80
[1008]81%pre
82getent group wsusoffline >/dev/null || groupadd -r wsusoffline
83
[1016]84
[1000]85%files
86%defattr(-,root,root)
[1008]87/usr/bin/wsus-*.sh
[1016]88%dir %{DEST_DIR}
[1010]89# #{DEST_DIR}/bin
90# #{DEST_DIR}/cmd
91%{DEST_DIR}/doc
92%{DEST_DIR}/static
93%{DEST_DIR}/xslt
94
[1008]95%defattr(-,root,wsusoffline)
96%{DEST_DIR}/client/
[1013]97%{DEST_DIR}/exclude/
[1010]98%{DEST_DIR}/iso/
99%{DEST_DIR}/log/
[1012]100%{DEST_DIR}/sh/
[1010]101%{DEST_DIR}/temp/
[1000]102
103%changelog
Note: See TracBrowser for help on using the repository browser.