source: opsi/server/wsusoffline/wsusoffline.spec@ 1018

Last change on this file since 1018 was 1018, checked in by joergs, on Jun 5, 2012 at 12:09:35 PM

adapted to build again at SUSE and RedHat

File size: 3.1 KB
RevLine 
[1000]1#
2# spec file for package [spectemplate]
3#
[1001]4# Copyright (c) 2012 dass IT GmbH, Cologne, Germany.
[1000]5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
[1001]15# Please submit bugfixes or comments via packager@dass-it.de
[1000]16#
17# norootforbuild
18
19Name: wsusoffline
20Group: System/Management
[1009]21Version: 7.3.2
22%define ver "732"
[1000]23Release: 1
24Summary: WSUS Offline Update: download Microsoft updates
25License: GPLv2+
26URL: http://www.wsusoffline.net/
27Source: %{name}_%{version}.orig.tar.gz
[1014]28#Source99: #{name}-rpmlintrc
[1004]29BuildRoot: %{_tmppath}/%{name}-%{version}-build
[1017]30BuildRequires: unzip
31
32# for goupadd
[1018]33%if 0%{?suse_version}
34#Requires(pre): shadow-utils
35#else
[1017]36Requires(pre): pwdutils
37%endif
[1018]38Requires(pre): /usr/bin/groupadd
[1017]39
[1018]40
[1001]41Requires: cabextract dos2unix md5deep xmlstarlet wget
[1000]42BuildArch: noarch
43
44%description
[1001]45"WSUS Offline Update" allows you to download most Microsoft updates and store them localy.
[1002]46This includes Windows, Office and some extensions like dotnet or Powershell.
[1001]47After downloading, they can be installed on any Microsoft Windows system without an Internet connection.
48Also unattended/silient installation are possible, so the update be be included easily in a Windows software management system like http://www.opsi.org
[1000]49
50%prep
51%setup -c
52
53
54%build
55
56
57
58%install
[1010]59%define DEST_DIR /var/lib/wsusoffline/
[1000]60mkdir -p $RPM_BUILD_ROOT/var/lib/
[1008]61unzip wsusoffline/%{name}%{ver}.zip -d $RPM_BUILD_ROOT/var/lib/
[1016]62install -d $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
63
64
65# remove windows only stuff
[1010]66rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.exe
67rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/*.au3
68rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/bin
69rm -r $RPM_BUILD_ROOT/%{DEST_DIR}/cmd
[1013]70
[1016]71# adapt permissions
72chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}
73find $RPM_BUILD_ROOT/%{DEST_DIR}/client/ -type d -exec chmod g+ws {} \;
74chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/exclude/
75chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/log/
76chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/iso/
77chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/sh/
78chmod a+x $RPM_BUILD_ROOT/%{DEST_DIR}/sh/*
79chmod g+ws $RPM_BUILD_ROOT/%{DEST_DIR}/temp/
80
81
82# install start wrapper scripts
[1001]83mkdir -p $RPM_BUILD_ROOT/usr/bin/
[1011]84install wsusoffline/*.sh $RPM_BUILD_ROOT/usr/bin/
[1000]85
[1016]86
87
[1000]88%clean
89rm -rf %{buildroot}
90
[1008]91%pre
92getent group wsusoffline >/dev/null || groupadd -r wsusoffline
93
[1016]94
[1000]95%files
96%defattr(-,root,root)
[1008]97/usr/bin/wsus-*.sh
[1016]98%dir %{DEST_DIR}
[1010]99# #{DEST_DIR}/bin
100# #{DEST_DIR}/cmd
101%{DEST_DIR}/doc
102%{DEST_DIR}/static
103%{DEST_DIR}/xslt
104
[1008]105%defattr(-,root,wsusoffline)
106%{DEST_DIR}/client/
[1013]107%{DEST_DIR}/exclude/
[1010]108%{DEST_DIR}/iso/
109%{DEST_DIR}/log/
[1012]110%{DEST_DIR}/sh/
[1010]111%{DEST_DIR}/temp/
[1000]112
113%changelog
Note: See TracBrowser for help on using the repository browser.